java.net member

Rechercher dans ce site

Loading...
Note:
Most of these plug-ins and articles are available completely for free! If you like them and/or find them useful, please donate any amount to keep this site actively developed

Si vous trouvez ces articles ou plug-ins utiles, n'hesitez pas a contribuer pour encourager l'auteur et garder le site actif n'importe quelle somme est la bienvenue

Installer JavaFX 1.1 plug-in d'Eclipse sur Linux

>> 20 February 2009

Un plug-in pour intégrer JavaFX dans Eclipse est disponible sur le site " Project Kenai ". Je l'ai testé sur Linux et il est compatible avec JavaFX 1.01 et 1.1.

Ce petit tutoriel a pour objectif de vous présenter l'installation du plug-in sur Linux

Téléchargez le plug-in sur le site de " kenai.com "
http://kenai.com/projects/eplugin/pages/Home

Un lien existe aussi sur le site de Sun



Sur cette page des liens pour télécharger le plug-in
Ou l'installer avec " update "
Un clic sur " Download "



Un clic sur le fichier " zip " pour Linux
com.sun.javafx.eclipse.feature-linux-gtk-x86-1.0.1.zip



Téléchargez Eclipse JEE
Il est nécessaire d'utiliser Eclipse version développeur JEE, car la palette de composants (Snippets) n'est disponible qu'avec cette version



Télécharger Eclipse JEE sur le site d'Eclipse

http://www.eclipse.org/downloads

Télécharger " Eclipse IDE for Java EE Developers ", sélectionnez la version 32 ou 64 bits selon votre version de Linux



Les composants nécessaires

Nous avons maintenant :

1.JavaFX SDK 1.1 ou (1.01)

Voyez dans le même Blog

Installer JavaFX 1.1 SDK sur Linux

http://java-javafx-iipt.blogspot.com/2009/02/installer-javafx-11-sdk-sur-linux.html

Installer JavaFX SDK sur Linux

http://java-javafx-iipt.blogspot.com/2009/02/installer-javafx-sdk-sur-linux.html

2.Eclipse IDE pour Java EE

3.Le plug-in de JavaFX d'Eclipse

" com.sun.javafx.eclipse.feature-linux-gtk-x86-1.0.1.zip "


Installez Eclipse
Il suffit de décompresser le fichier archive " .tar.gz " pour obtenir Eclipse

$ tar -zxvf eclipse-jee-ganymede-SR1-linux-gtk-x86_64.tar.gz



Note concernant l'installation du plug-in
Il est possible d'installer le plug-in en décompressant le fichier " .zip " du plug-in dans le même dossier où on a décompressé Eclipse, puis de démarrer Eclipse avec -clean.

En clair, exécutez les instructions suivantes sans changement de dossier :

$ tar -zxvf eclipse-jee-ganymede-SR1-linux-gtk-x86_64.tar.gz

$ unzip com.sun.javafx.eclipse.feature-linux-gtk-x86-1.0.1.zip


$ eclipse/eclipse -clean


Il est néanmoins conseillé d'utiliser " Update Software " mentionnée plus loin

Décompressez le plug-in


Créez un dossier (le nom du dossier est au choix) pour le plug-in et décompressez le plug-in. Nous allons utiliser ce dossier plus tard dans Eclipse

$ mkdir eclipse_plugin

Copier le plug-in dans le dossier

$ cp com.sun.javafx.eclipse.feature-linux-gtk-x86-1.0.1.zip eclipse_plugin

Changez de dossier

$ cd eclipse_plugin

Décompressez le fichier

$ unzip com.sun.javafx.eclipse.feature-linux-gtk-x86-1.0.1.zip



Lancez Eclipse

$ Chemin_vers_dossier_Eclipse/eclipse

Note :
Dans l'exemple le dossier d'installation d'Eclipse est " eclipse " (dossier obtenu par défaut en décompressant l'archive)



Installez le plug-in

Un clic sur le menu " Help " -> Software Updates



Un clic sur l'onglet " Available Software " -> un clic sur " Add Site "



Un clic sur " local "



Sélectionnez le dossier de décompression du plug-in
Dans l'exemple " eclipse_plugin "



Le dossier est ajouté
Un clic droit sur JavaFX Features -> Install (La case JavaFX Features doit être cochée)




JavaFX Feature est affiché
Un clic sur " Next "




Validez la licence
Un clic sur " Finish "



Re-démarrez Eclipse
Un clic sur " Yes "



Créez un projet Java
File -> New -> Project




Sélectionnez " Java Project " -> un clic sur " Next "



Entrez un nom de votre choix pour le projet
Note :
Il est vivement recommandé d'utiliser Java 6 update 12

Un clic sur " Finish "



Confirmez l'ouverture de " Java Perspective "
Un clic sur " Yes "



Ajoutez " Java Nature " dans le projet
Un clic droit sur le projet -> JavaFX -> Add JavaFX Nature





Un message d'erreur est affiché
JavaFX SDK n'a pas été trouvé. Un clic sur " OK " permet de configurer " JAVAFX_HOME "



Dans " Classpath Variables "
JAVAFX_HOME est marqué comme vide (empty)
Un clic sur " Edit "




Un clic sur " Folder "
pour sélectionner le dossier contenant JavaFX SDK (1.1 ou 1.01)



Sélectionnez le dossier de JavaFX SDK
Un clic sur " OK "



Le dossier est sélectionné
Un clic sur " OK "
Un autre clic sur " OK " dans " Classpath Variables "



Ajoutez un package dans le projet
Un clic droit sur " src " dans le projet -> New -> Package



Donnez un nom au package
Un clic sur " Finish "



Ajoutez un script JavaFX
Un clic droit sur le package que nous avons ajouté -> New -> Empty Script



Donnez un nom au script
Entrez " Main " le fichier aura comme nom " Main.fx "
Un clic sur " Finish "



Le script est ouvert dans l’éditeur
La palette d'outils est prête



Ajoutez un composant " Stage "
Cliquez sur " Stage " -> gardez le bouton pressé -> allez à l’intérieur de l'éditeur -> lâcher le bouton
Ou bien
Clic droit sur " Stage " -> " Insert "



Une fenêtre de configuration est ouverte
Cette fenêtre contient les propriétés du Stage
Modifiez et Validez en cliquant sur " Insert "



Ajoutez un composant
Glissez de la palette vers l'éditeur
ou
Un clic où vous désirez placer le composant -> clic droit sur le composant -> insert



Exécutez le script
Sauvegardez puis un clic droit sur le fichier " Main.fx " -> " Run As " -> " JavaFX Application "




Les configurations sont affichées
Modifiez si besoin
Un clic sur " Run "



Et voilà le code est exécuté



Merci

2 comments:

Anonymous,  April 6, 2009 at 5:23 PM  

très utile merci,

par contre on a un pb d'intégration si on utilise la sdk1.1 (dans http://updates.netbeans.org/netbeans/updates/6.5.1/uc/final/stable/patch3/javafx2/org-netbeans-modules-javafx-sdk-mac.nbm)

"Description Resource Path Location Type
incompatible types found : Integer required: com.sun.javafx.runtime.location.FloatVariable Test.fx Test/src/fr/helmet/test line 9 JavaFX Problem"

Donc on est passé à la sdk1.0 (récupéré dans http://updates.netbeans.org/netbeans/updates/6.5.1/uc/final/stable/modules/javafx/org-netbeans-modules-javafx-sdk-mac.nbm)

Une question : savez vous comment faire pour poouvoir choisir le profil "mobile" comme expliqué dans le tuto du plugin http://download.java.net/general/javafx/eclipse/tutorial.html#configOpt. ?

Chez nous l'option est désactivée, on ne peut pas la cocher.


bye

okjavafx April 6, 2009 at 8:40 PM  

Bonjour,

Quelle OS utilisez-vous ?

Le run-time et l'émulateur existe uniquement pour Windows

http://java.sun.com/javafx/1/reference/sdk-install/

Post a Comment

  © Blogger template Simple n' Sweet by Ourblogtemplates.com 2009

Back to TOP